marty.net 1001 Postcards Love Love Love Meep Meep ZenZodiac DailyQuotation

YOU ARE HERE:
PROBLEM with sections dissappearing - NEED FIX

HOME

CPSHOP|

|

|

EMAIL MARTY
  marty.net message board
  « PROBLEM with sections dissappearing - NEED FIX »
Welcome, Guest. Please Login or Register.
05/27/17 at 06:12:05
Home Help Search Login Register
   marty.net message board
   About cpshop
   General cpshop Support
   PROBLEM with sections dissappearing - NEED FIX
(Moderator: Marty)
Pages: « 1 2 Reply Notify of replies Send the topic Print 
   Author  Topic: PROBLEM with sections dissappearing - NEED FIX  (Read 4572 times)
flowergarden
Silver Dragon
***

Posts: 46




   

Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #15 on: 05/30/13 at 05:20:12 »
Reply with quote Modify message

@skoonk If you ever have the script ready for sale, please be sure to let us know. I know other shopkeepers would be interested, myself included. Thank you.
Logged
dmp65
Gold Dragon
****

Posts: 57



Go Scots!
   

Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #16 on: 05/30/13 at 13:10:12 »
Reply with quote Modify message



on 05/30/13 at 05:20:12, flowergarden wrote:
@skoonk If you ever have the script ready for sale, please be sure to let us know. I know other shopkeepers would be interested, myself included. Thank you.


+1 on that! I really like what I've been able to do with cpshop but am now concerned that if something breaks, I have nowhere to turn for help. I wish Marty would clarify his position regarding future support (even if it cost a nominal annual fee to make it worth his while).

@skoonk, your store looks great and I love the way you've set it up so when a product category is selected, all of the products in that category slide into view. Very cool! I wish I knew how to do that.
Logged
dmp65
Gold Dragon
****

Posts: 57



Go Scots!
   

Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #17 on: 03/16/14 at 21:21:13 »
Reply with quote Modify message

My sections have now disappeared. I didn't change anything on my end, so I have to assume Cafepress did. I tried emptying my cache and that won't work now either. I get the following message:
(error code: noconnection 6) (301 Moved Permanently)

Has anyone encountered this before and/or found a solution? I'm going to have to shut down my store if I can't get this figured out. Any help is appreciated.
Logged
T-Shirt-Painter
Green Dragon
*

Posts: 8



Go Scots!
   

E-Mail
Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #18 on: 03/16/14 at 23:53:28 »
Reply with quote Modify message

I still use version 2.7 and my sections, products and cart are working.
Logged
T-Shirt-Painter
Green Dragon
*

Posts: 8



Go Scots!
   

E-Mail
Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #19 on: 03/17/14 at 11:01:23 »
Reply with quote Modify message

Just to test for someone, I cleared the cache and now it is gone.
Logged
Bradley W. Schenck
Gold Dragon
****

Posts: 242



Go Scots!
   

WWW
Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #20 on: 03/18/14 at 11:27:33 »
Reply with quote Modify message

Yeah, well, if your CPShop is still displaying sections, don't clear the cache--set it to "only when I clear the CPShop cache" in the admin page.

I can see that even in an affected shop the product pages seem to work, though product images may be displayed in an odd aspect ratio.

On a section page, in place of the table of thumbnails there's just a commented list of every Cafepress store/section that was  defined in the ShopID field in CPShop admin.
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #21 on: 04/06/14 at 01:47:20 »
Reply with quote Modify message

Note: I am still fully retired.  This is a one-shot deal.

I've attempted to put up a fix to this "moved permanently" issue.  For clarity's sake, it is an attempt by CafePress to block cpshop (again).  This update attempts to circumvent the issue, but it's only a matter of time before they do something more drastic.

Anyway, if you download and install the latest update (2.8x), I think it'll work.  Though you may want to take extra precautions beforehand, to make sure it works on your system, or wait for someone else more daring to confirm that it works.

I can't promise it'll work on all servers; it's using perl's LWP-UserAgent library, and I don't know that all webhosts offer it.  But it's the best solution I could think of that wouldn't require a complete rewrite or something equally time consuming.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Danes-R-Us
White Dragon
**

Posts: 15



Go Danes!
   

WWW
Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #22 on: 04/06/14 at 06:39:07 »
Reply with quote Modify message

Daring here - downloaded the most recent unix update and sent it to my server... all is working except it did bust the "keep shopping" fix from here: http://www.marty.net/cgi/marty/board/messageboard?action=display&board=cphelp&num=1313325444&start=0#10

Other than that, no issue as of yet.

Hosting at Bluehost with shared standard unix plan.

Thanks Marty!!
Logged
oph3lia
Gold Dragon
****

Posts: 58



Go Scots!
   

E-Mail
Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #23 on: 04/07/14 at 11:48:43 »
Reply with quote Modify message

Thank you very much for taking the time to help, Marty!

I d/l the unix update, and it seems to do the trick, knock on wood.

I did find that I had to delete a file that I had from a previous time (I think it was have been from the old "betafix"?) cpdomain.txt, because that was causing problems.

(I had never fixed the keep shopping, so I can't say if it made a difference to that or not.)

Logged
T-Shirt-Painter
Green Dragon
*

Posts: 8



Go Scots!
   

E-Mail
Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #24 on: 04/10/14 at 11:39:19 »
Reply with quote Modify message

Dina, tried to email you back but it is bouncing back to me.

There is a fix on the Great Gear Facebook group.  A zip file with 2 things to upload.  Cookies txt file and a LIB file.  

I uploaded the files into the Store folder, where the index is. At the File Manager I could not right click the file to set permissions, but it works anyway. In the Store folder, it fixes both shops, so I updated the cache in the other shop and now that one is updated too.

Here is the zip file.
http://www.shop.fashionstinks.com/shop/cpshopfix3262014.zip
Logged
flowergarden
Silver Dragon
***

Posts: 46




   

Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #25 on: 05/30/14 at 21:32:41 »
Reply with quote Modify message

It did not work for me!  All of my stores are BLANK except for the thumbnails. I use the update Marty mentioned and did "755" cmod, but nothing.

Anyone else know of another fix?  Maybe I missed a step.
« Last Edit: 05/30/14 at 21:33:49 by flowergarden » Logged
flowergarden
Silver Dragon
***

Posts: 46




   

Re: PROBLEM with sections dissappearing - NEED FIX
« Reply #26 on: 07/05/14 at 16:51:21 »
Reply with quote Modify message

So is CPShop dead now?  None of these tips worked.  Anyone?
Logged
Pages: « 1 2 Reply Notify of replies Send the topic Print 
Jump to:


marty.net message board (http://www.marty.net/cgi/marty/board/messageboard)

Powered by YaBB 1 Gold - Release (Yet Another Bulletin Board)
Copyright © 2000-2001, X-Null. All Rights Reserved.