marty.net 1001 Postcards Love Love Love Meep Meep ZenZodiac DailyQuotation

YOU ARE HERE:
Clean URL Problem

HOME

CPSHOP|

|

|

EMAIL MARTY
  marty.net message board
  « Clean URL Problem »
Welcome, Guest. Please Login or Register.
12/16/17 at 22:26:57
Home Help Search Login Register
   marty.net message board
   About cpshop
   Customization Help
   Clean URL Problem
(Moderator: Marty)
Pages: 1 Reply Notify of replies Send the topic Print 
   Author  Topic: Clean URL Problem  (Read 860 times)
Nathan
Guest

E-Mail
Clean URL Problem
« on: 04/01/03 at 05:19:25 »
Reply with quote Modify message

I am running on a Raq server running Unix, and cannot get the clean store URLs to resolve.  I am afraid that My Dog Murphy's great position in Google will disappear with CPShop.  

How do I get this to work?

Nathan
http://www.mydogmurphy.com
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: Clean URL Problem
« Reply #1 on: 04/01/03 at 10:06:44 »
Reply with quote Modify message

RAQ servers are configured oddly -- they don't inherently support the PATH_INFO environment variable.

However, I will try to come up with some sort of workaround.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: Clean URL Problem
« Reply #2 on: 04/01/03 at 14:55:42 »
Reply with quote Modify message

Nathan,

Could you try placing this line in your mdm.cgi file, right underneath the $script_dir line:

$ENV{'PATH_INFO'} =~ s|.*\.cgi||;

Then turn on clean URLs, and test your store.  I'd like to see if that happens to fix the problem.  It probably won't be the final solution, but it'll at least give me an idea if I'm on the right track.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Nathan
Guest

E-Mail
Re: Clean URL Problem
« Reply #3 on: 04/09/03 at 14:14:51 »
Reply with quote Modify message

Nope, does not work.  Still passes info in the URL, and when it gets to the product page it tells me:

/cgi-bin/mdm.cgi/mydogmurphy.53717 The configuration file (mydogmurphy.53717.config) has not been generated.  Please run the administration script before proceeding.

Nathan
http://www.mydogmurphy.com
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: Clean URL Problem
« Reply #4 on: 04/10/03 at 00:22:25 »
Reply with quote Modify message

Okay, let's try this instead, in the same place:

$ENV{'PATH_INFO'} =~ s|.*\.cgi||;
$ENV{'SCRIPT_NAME'} =~ s|\.cgi/.*|.cgi|;
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
nathanrudy
Guest

E-Mail
Re: Clean URL Problem
« Reply #5 on: 10/02/05 at 12:46:55 »
Reply with quote Modify message

2.0 finally fixes this issue!  Yippee!
Logged
Pages: 1 Reply Notify of replies Send the topic Print 
Jump to:


marty.net message board (http://www.marty.net/cgi/marty/board/messageboard)

Powered by YaBB 1 Gold - Release (Yet Another Bulletin Board)
Copyright © 2000-2001, X-Null. All Rights Reserved.