marty.net 1001 Postcards Love Love Love Meep Meep ZenZodiac DailyQuotation

YOU ARE HERE:
Store Template w/ SSI and JS

HOME

CPSHOP|

|

|

EMAIL MARTY
  marty.net message board
  « Store Template w/ SSI and JS »
Welcome, Guest. Please Login or Register.
12/13/17 at 09:04:23
Home Help Search Login Register
   marty.net message board
   About cpshop
   Customization Help
   Store Template w/ SSI and JS
(Moderator: Marty)
Pages: 1 Reply Notify of replies Send the topic Print 
   Author  Topic: Store Template w/ SSI and JS  (Read 747 times)
aliengrey
Guest

E-Mail
Store Template w/ SSI and JS
« on: 04/22/03 at 00:37:33 »
Reply with quote Modify message

Marty -
I was switching over my site navigation to dynamic drop-down menu which is a SSI. Not a big deal, but this particular code also needs access to a Javascript in order to function properly. Seems the main nav loads (visually) but fails to execute (on the Store Temp page). Then I remembered something about not being able to call a JS from within a cgi-bin. Doh! *smack head*

I'm sure you're cpShop script allows for this sort of thing--I'm just not sure how to do it. Help!?

Here's URL:
http://www.alien-technology.com/cgi-bin/store/crop_circles_101
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: Store Template w/ SSI and JS
« Reply #1 on: 04/22/03 at 09:48:58 »
Reply with quote Modify message

Put the js folder in the root directory on your server, and reference it with a slash (turning it into an absolute path instead of a relative one):

Old: <script type="text/javascript" src="js/menumachine.js"></script>
References: www.alien-technology.com/cgi-bin/store/js/menumachine.js

New: <script type="text/javascript" src="/js/menumachine.js"></script>
References: www.alien-technology.com/js/menumachine.js

It actually looks like you've already got the menumachine script in that folder.  If you can use the one that's already in there, that's fine.  If you can't, then simply create a subdirectory, and place the files in there:

New: <script type="text/javascript" src="/js/cpshop/menumachine.js"></script>
References: www.alien-technology.com/js/cpshop/menumachine.js
« Last Edit: 04/22/03 at 09:50:13 by Marty » Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
aliengrey
Guest

E-Mail
Re: Store Template w/ SSI and JS
« Reply #2 on: 04/22/03 at 13:58:40 »
Reply with quote Modify message

Okay, I added the slash -- Replaced the original hard coded nav with the SSI -- Uploaded and the SSI navigation worked great, BUT... The cpShop items did not load. Apparently the code reformatted and removed the "<" and ">" from the <[title]> and <[content]> tags.

No big deal - I added them back.

Here's the weird thing.
The cpShop products loaded fine, but the navigation stopped working. *scratch head*

Either I'm missing something else or there's some conflict - or both.

Thoughts/Suggections?

thanks!


Logged
aliengrey
Guest

E-Mail
Re: Store Template w/ SSI and JS
« Reply #3 on: 04/22/03 at 14:18:18 »
Reply with quote Modify message

Yep, something funny going on.

When I remove "<[content]>" from the store template, the navigation works -- put it back, and it stops working.

*What am I missing?*
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: Store Template w/ SSI and JS
« Reply #4 on: 04/25/03 at 09:41:43 »
Reply with quote Modify message

Okay, I'm a little confused by the problem itself.

Your first problem is that you don't have the latest .lib files -- you should download the latest update.  That may begin to fix the zoom images not working.

What concerns me more is that the new zoom image system calls a javascript function called "e", which is also the name of an object in your menumachine javascript.  That might cause a conflict.

Other than that, I can't really figure out what the problem is -- and by that, I mean that I don't see a problem at all.  I can navigate around your site just fine with the dynamic menu system, and cpshop looks like it's loading and working perfectly as well, in both IE and Mozilla/Netscape.

If there is a problem, it looks to me like it's a rendering issue.  I've noticed that when I click on a page in IE, it takes a second or two to render the dynamic menu and anything below it, even though the status bar says "Done."  Is that the problem you're referring to?
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
aliengrey
Guest

E-Mail
Re: Store Template w/ SSI and JS
« Reply #5 on: 04/25/03 at 18:51:56 »
Reply with quote Modify message

Hi Marty -

Thanks for checking into this.

Thanks for the heads up. The last email update I got was for "cpshop1.4d.jb" so I must have missed it. New version now installed but the problem is still there.

Problem: Mac OS 9.2 - IE 5.1.6
The nav loads and displays - just doesn't execute on my "store_temp" file (drop-downs don't drop and even though the cursor changes from arror to hand on hover, still won't allow the links to click).

If there's two javascript functions called "e", then maybe that is the problem.

60k question: How do I go about fixing this? I have also alerted the MenuMeachine folks about this but have yet to hear back.

Thanks.
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: Store Template w/ SSI and JS
« Reply #6 on: 04/25/03 at 21:23:20 »
Reply with quote Modify message

Hmm...Mac problem.  That make it considerably more difficult for me to troubleshoot, since I don't own a Mac.

I don't know if this works on the Mac version of IE, but double-clicking on the icon in the left-bottom corner of the browser window typically displays the pertinent javascript error messages.  You could try using the menumachine menus, and then double-clicking on that icon -- perhaps it'll give you an error message of some kind that could help.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
aliengrey
Guest

E-Mail
Re: Store Template w/ SSI and JS
« Reply #7 on: 04/26/03 at 08:21:43 »
Reply with quote Modify message

On Mac/IE, Java Messages can be viewed via "View -> Java Messages" from the main OS toolbar. Tried it, but didn't show any errors.

Also:
It seems to be contained to MAC/IE because everything works correctly in MAC/NS.

As you mentioned earlier, it appears the page(s) in question look fully loaded but the status bar shows it is still trying to load.

I'm befuddled. Unless I can figure out a solution, I'll have to dump the navigation all together.

If you come up with a fix, please let me know.

Thanks for your help.
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: Store Template w/ SSI and JS
« Reply #8 on: 04/26/03 at 16:08:45 »
Reply with quote Modify message

Hmm...just to clarify, there's a difference between Java and Javascript -- they're two totally different technologies that just happen to be similarly named.

Hmm...have you asked anyone else with a Mac and IE if they could try out your site, to see if the problem is possibly just limited to your personal computer's installation of IE?  It might be worth a shot.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Pages: 1 Reply Notify of replies Send the topic Print 
Jump to:


marty.net message board (http://www.marty.net/cgi/marty/board/messageboard)

Powered by YaBB 1 Gold - Release (Yet Another Bulletin Board)
Copyright © 2000-2001, X-Null. All Rights Reserved.