marty.net 1001 Postcards Love Love Love Meep Meep ZenZodiac DailyQuotation

YOU ARE HERE:
Problem with page 2 and 3 not working

HOME

CPSHOP|

|

|

EMAIL MARTY
  marty.net message board
  « Problem with page 2 and 3 not working »
Welcome, Guest. Please Login or Register.
12/17/17 at 13:58:57
Home Help Search Login Register
   marty.net message board
   About cpshop
   Customization Help
   Problem with page 2 and 3 not working
(Moderator: Marty)
Pages: 1 Reply Notify of replies Send the topic Print 
   Author  Topic: Problem with page 2 and 3 not working  (Read 552 times)
Nathan
Guest

E-Mail
Problem with page 2 and 3 not working
« on: 05/22/03 at 17:48:54 »
Reply with quote Modify message

http://www.dems.us/index.htm

If you click on the [gifts] link on the tally of candidates you get to page one of the items.

However, if you click on page 2 all you get is the main store page!  It does not go to the second page of products!

This is really weird, because if you use the main store page to go to the products page, it does work.  

The difference is that I removed the breadcrumbs and other trail information from the links on the home page so that search engines might follow, so the link is just http://www.dems.us/cgi-bin/cpshop.cgi?storeid=2004primary.99401 instead of http://www.dems.us/cgi-bin/cpshop.cgi?storeid=2004primary.99401&page=1&trail=2004primary~Bumper%20Sticker%20Primary~2&st=Anyone%20But%20Bush%20for%20President

Has anyone else seen this?
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: Problem with page 2 and 3 not working
« Reply #1 on: 05/23/03 at 09:28:48 »
Reply with quote Modify message

I'll try to figure it out today.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: Problem with page 2 and 3 not working
« Reply #2 on: 05/23/03 at 18:35:10 »
Reply with quote Modify message

Unfortunately, as with most CGI scripts, you can't simply remove the variables from the URL and expect it to work -- cpshop needs those variables to assemble the page and links correctly.

Now, if you could use Clean URLs, it might have a chance at working, though I'm not even sure of that.  Though you're on a Cobalt server, which doesn't support Clean URLs, making it a moot point.

The other thing you could do is add store sections manually, as store IDs, instead of letting cpshop duplicate your premium store.  If you add each store section as an individual store ID (i.e. mystoreid.13124), cpshop will use fewer variables in creating the first page.  It still won't support Clean URLs on your server, but it'll be a lot less gobbledygook than it is now.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
nathanrudy
Guest

E-Mail
Re: Problem with page 2 and 3 not working
« Reply #3 on: 06/01/03 at 18:51:05 »
Reply with quote Modify message

Logged
Pages: 1 Reply Notify of replies Send the topic Print 
Jump to:


marty.net message board (http://www.marty.net/cgi/marty/board/messageboard)

Powered by YaBB 1 Gold - Release (Yet Another Bulletin Board)
Copyright © 2000-2001, X-Null. All Rights Reserved.