marty.net 1001 Postcards Love Love Love Meep Meep ZenZodiac DailyQuotation

YOU ARE HERE:
not returning a complete set of HTTP headers

HOME

CPSHOP|

|

|

EMAIL MARTY
  marty.net message board
  « not returning a complete set of HTTP headers »
Welcome, Guest. Please Login or Register.
12/14/17 at 10:12:58
Home Help Search Login Register
   marty.net message board
   About cpshop
   Installation Help
   not returning a complete set of HTTP headers
(Moderator: Marty)
Pages: « 1 2 3 4 » Reply Notify of replies Send the topic Print 
   Author  Topic: not returning a complete set of HTTP headers  (Read 166321 times)
robbiebow
Guest

E-Mail
Re: not returning a complete set of HTTP headers
« Reply #15 on: 01/31/05 at 08:25:08 »
Reply with quote Modify message

If you find the problem doesn't occur all the time, you may find the problem lies with IIS6. The following Microsoft Hotfix might be of interest:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;884764
Logged
Mike
Guest

E-Mail
Re: not returning a complete set of HTTP headers
« Reply #16 on: 02/18/05 at 11:40:41 »
Reply with quote Modify message

Thanks, I'm always surprised at how many people help others - invest time and effort. These Forums help others that only read the postings and on many occasions have I found the correct answer or some hint to guide me to a solution. So here is a thanks to all of you who help others.

Mike
Logged
Ravindra Ramouthar
Guest

E-Mail
Re: not returning a complete set of HTTP headers
« Reply #17 on: 04/25/05 at 02:23:47 »
Reply with quote Modify message

Actually, the KB hotfix detailed in Article ID 839229 doesn't appear to solve this problem.

Any other suggestions?

Ravindra Ramouthar
Logged
Mondor
Guest

E-Mail
Re: not returning a complete set of HTTP headers
« Reply #18 on: 06/07/05 at 20:13:25 »
Reply with quote Modify message

I was have the same problem, and your answer, help me much. Thank you !

on 08/03/04 at 09:32:30, Srini wrote:
access the Internet Services Manager through the following path:

Start->Settings->Control Panel->Administrative Tools->Internet Services
Manager.

Then expand the tree until you see "Default Web Site" and right-click on it and select Properties. Then select the "Home Directory" tab, then click on the "Configuration..." button under "Application Settings."

Now you'll see the "Application Configuration" dialog, where the "App Mappings" tab should be active. Scroll through the list and find the one for ".pl", then click on Edit.

You will want to keep the file path, but change the perl.exe to "perlis.dll". And remove the "%$" after the file name.

Save your changes and then restart your web server to ensure the changes take affect and hopefully that will give you better luck with avoiding those random CGI errors.
Logged
scubaholic
Guest

E-Mail
Re: not returning a complete set of HTTP headers
« Reply #19 on: 09/23/05 at 04:49:39 »
Reply with quote Modify message

I was having the same problem but now it's all working, phew...

You need to change from perl.exe to perlis.dll not only under configuration in the folder you want to run your cgi, BUT ALSO in 'Web Service Extensions'

Logged
MichaelLee
Guest

E-Mail
Re: not returning a complete set of HTTP headers
« Reply #20 on: 10/06/05 at 06:52:15 »
Reply with quote Modify message

[td]Where is the "Web Service Extensions? Thanks [/td]
Logged
Skreid
Gold Dragon
****

Gender: male
Posts: 53



T`is Me
   

WWW E-Mail
Re: not returning a complete set of HTTP headers
« Reply #21 on: 10/10/05 at 12:35:38 »
Reply with quote Modify message

Marty,

Did you ever work out a solution to this problem?

I can't get any of the 2.0 releases to work on my windows server, keep getting the incorrect headers msg.


Quote:
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

Not enough arguments for mkdir at cppage.lib line 276, near ""${script_dir}cpcache")"
BEGIN not safe after errors--compilation aborted at cppage.lib line 647.


I don't have admin access to my server so I cna't change the ISS settings. Is there anything else you cna think off?

Stuart
« Last Edit: 10/10/05 at 13:02:34 by Skreid » Logged

--
Skreid Studios

The St.Andrews Store
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: not returning a complete set of HTTP headers
« Reply #22 on: 10/12/05 at 02:58:54 »
Reply with quote Modify message

Stuart, did you create the cpcache directory when you installed?
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Skreid
Gold Dragon
****

Gender: male
Posts: 53



T`is Me
   

WWW E-Mail
Re: not returning a complete set of HTTP headers
« Reply #23 on: 10/12/05 at 06:21:06 »
Reply with quote Modify message

Yup,

then deleted and recreated after that message.

I've tried a number of different installs/upgrades/fresh installs and it always gives the same error.

I' emailed you server details if you'd like to check it out somemore. Asuming you have the time ..

Cheers

Stuart.
Logged

--
Skreid Studios

The St.Andrews Store
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: not returning a complete set of HTTP headers
« Reply #24 on: 10/12/05 at 10:42:18 »
Reply with quote Modify message

Also, have you entered the $script_dir into your cpshop.cgi/cpshop.pl file?
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Skreid
Gold Dragon
****

Gender: male
Posts: 53



T`is Me
   

WWW E-Mail
Re: not returning a complete set of HTTP headers
« Reply #25 on: 10/12/05 at 13:08:17 »
Reply with quote Modify message

Yup, script_dir is set correctly.

edit* I've just tried rc7 and it makes no difference, still getting the same error msg.

Stuart
« Last Edit: 10/12/05 at 13:10:49 by Skreid » Logged

--
Skreid Studios

The St.Andrews Store
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: not returning a complete set of HTTP headers
« Reply #26 on: 10/13/05 at 23:53:06 »
Reply with quote Modify message

Okay, I believe the problem only exists in really old versions of perl.  There appears to be an issue where older perl installs require the line:

mkdir("${script_dir}cpcache");

to be written as:

mkdir("${script_dir}cpcache", 0777);

Stuart, if you're feeling particularly daring, could you try changing that line in cppage.lib, and see if your problem goes away?  If it does, I'll add that to the next update.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: not returning a complete set of HTTP headers
« Reply #27 on: 10/14/05 at 02:31:20 »
Reply with quote Modify message

Try downloading rc8, and see if the problem goes away.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Skreid
Gold Dragon
****

Gender: male
Posts: 53



T`is Me
   

WWW E-Mail
Re: not returning a complete set of HTTP headers
« Reply #28 on: 10/14/05 at 05:56:02 »
Reply with quote Modify message

Cheers marty,

rc8 works, almost, there is a few slight problems but I think I can solve them with a little bit of tweaking.

Stuart
Logged

--
Skreid Studios

The St.Andrews Store
ahovious
Guest

E-Mail
Re: not returning a complete set of HTTP headers
« Reply #29 on: 10/19/05 at 10:34:13 »
Reply with quote Modify message

I am having the same problem. What is the rc8 and how do i get it?

Thanks in Advance!



on 10/12/05 at 13:08:17, Skreid wrote:
Yup, script_dir is set correctly.

edit* I've just tried rc7 and it makes no difference, still getting the same error msg.

Stuart
Logged
Pages: « 1 2 3 4 » Reply Notify of replies Send the topic Print 
Jump to:


marty.net message board (http://www.marty.net/cgi/marty/board/messageboard)

Powered by YaBB 1 Gold - Release (Yet Another Bulletin Board)
Copyright © 2000-2001, X-Null. All Rights Reserved.