marty.net 1001 Postcards Love Love Love Meep Meep ZenZodiac DailyQuotation

YOU ARE HERE:
moved to a new server & reinstalled, now 0 work

HOME

CPSHOP|

|

|

EMAIL MARTY
  marty.net message board
  « moved to a new server & reinstalled, now 0 work »
Welcome, Guest. Please Login or Register.
12/14/17 at 13:16:48
Home Help Search Login Register
   marty.net message board
   About cpshop
   Installation Help
   moved to a new server & reinstalled, now 0 work
(Moderator: Marty)
Pages: 1 Reply Notify of replies Send the topic Print 
   Author  Topic: moved to a new server & reinstalled, now 0 work  (Read 2120 times)
cjsherlock
Silver Dragon
***

Posts: 42



I'd Rather Be Diving!
   

WWW
moved to a new server & reinstalled, now 0 work
« on: 08/25/08 at 12:03:30 »
Reply with quote Modify message

Marty and others,
after having some difficulty with my last host (they kept reinstalling features that would break my store, I would complain then they would uninstall ect...) I moved to Blue Host.

I have one version working perfectly there....
Now my new store I can't get working..
I get a 500 error when trying to access my cpadmin page, cptest ect.
I triplechecked my permissions and they appear correct.
Here is the error log from the host:
Error Logs

[Mon Aug 25 12:56:08 2008] CURRENT SERVER TIME
--------------------------------------------------------------------------------
MAIN error_log:
--------------------------------------------------------------------------------

[Mon Aug 25 12:56:06 2008] [error] [client 69.90.42.67] Invalid URI in request GET  HTTP/1.1


--------------------------------------------------------------------------------
SUEXEC error_log:
--------------------------------------------------------------------------------

[2008-08-25 12:50:52]: uid: (2853/seasquir) gid: (2853/seasquir) cmd: cpadmin.cgi
[2008-08-25 12:50:52]: directory is writable by others: (/home1/seasquir/public_html/cgi-bin/store)
[2008-08-25 12:50:52]: uid: (2853/seasquir) gid: (2853/seasquir) cmd: 500.php
[2008-08-25 12:50:52]: file has no execute permission: (/home1/seasquir/public_html/500.php)
[2008-08-25 12:54:44]: uid: (2853/seasquir) gid: (2853/seasquir) cmd: cptest.cgi
[2008-08-25 12:54:44]: directory is writable by others: (/home1/seasquir/public_html/cgi-bin/store)
[2008-08-25 12:54:44]: uid: (2853/seasquir) gid: (2853/seasquir) cmd: 500.php
[2008-08-25 12:54:44]: file has no execute permission: (/home1/seasquir/public_html/500.php)
[2008-08-25 12:54:58]: uid: (2853/seasquir) gid: (2853/seasquir) cmd: seasquirrel.cgi
[2008-08-25 12:54:58]: directory is writable by others: (/home1/seasquir/public_html/cgi-bin/store)
[2008-08-25 12:54:58]: uid: (2853/seasquir) gid: (2853/seasquir) cmd: 500.php
[2008-08-25 12:54:58]: file has no execute permission: (/home1/seasquir/public_html/500.php)


--------------------------------------------------------------------------------
PHP error_log:
--------------------------------------------------------------------------------

/home1/seasquir/public_html/support/api/error_log:
[24-Aug-2008 18:28:34] PHP Warning:  session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cookie - headers already sent in /home1/seasquir/public_html/support/main.inc.php on line 48
[24-Aug-2008 18:28:34] PHP Warning:  session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent in /home1/seasquir/public_html/support/main.inc.php on line 48

thanks for any help
the store is located at
www.seasquirrelproductions.net/cgi-bin/store/
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: moved to a new server & reinstalled, now 0 wor
« Reply #1 on: 08/25/08 at 18:24:08 »
Reply with quote Modify message

Try chmodding your cgi-bin/store directory to 755 instead of 777, and see if that helps.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: moved to a new server & reinstalled, now 0 wor
« Reply #2 on: 08/25/08 at 18:24:48 »
Reply with quote Modify message

Oh, and also note that at Bluehost you don't need to use the cgi-bin/store directory.  You can just create a store directory in the web root if you like.
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
cjsherlock
Silver Dragon
***

Posts: 42



I'd Rather Be Diving!
   

WWW
Re: moved to a new server & reinstalled, now 0 wor
« Reply #3 on: 08/25/08 at 20:10:20 »
Reply with quote Modify message

Thank you marty! changing to 755 worked!

What is the benifit of running not in the cgi-bin folder?
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: moved to a new server & reinstalled, now 0 wor
« Reply #4 on: 08/25/08 at 21:46:11 »
Reply with quote Modify message

Just having shorter URLs, really (if you're not using php).

It also allows you to change cpshop.cgi to index.cgi, so for people not using php wrappers,  you'd be able to access your shop at /store/ (though it may require a custom .htaccess file).
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
glau
Gold Dragon
****

Posts: 56



Go Scots!
   

WWW
Re: moved to a new server & reinstalled, now 0 wor
« Reply #5 on: 11/26/10 at 11:37:41 »
Reply with quote Modify message



on 08/25/08 at 18:24:08, Marty wrote:
Try chmodding your cgi-bin/store directory to 755 instead of 777, and see if that helps.


I think this should go in the install instructions, I have been trying to work out why my new store does not work and I finally found this which solved everything. Maybe you could put a line in to say "Try using 755 instead of 644"...... If I remember correctly this happened to me in the past too....
Logged

Scare friends with Shocking TShirts
Eco Tees
Jewel Jubic
Green Dragon
*

Gender: male
Posts: 1



Go Scots!
  broadband broadband   broadband

E-Mail
Re: moved to a new server & reinstalled, now 0 wor
« Reply #6 on: 07/09/11 at 07:39:15 »
Reply with quote Modify message

There must be some instruction manual that can guide you well..got any help!!
Logged

business line rental
Pages: 1 Reply Notify of replies Send the topic Print 
Jump to:


marty.net message board (http://www.marty.net/cgi/marty/board/messageboard)

Powered by YaBB 1 Gold - Release (Yet Another Bulletin Board)
Copyright © 2000-2001, X-Null. All Rights Reserved.