marty.net 1001 Postcards Love Love Love Meep Meep ZenZodiac DailyQuotation

YOU ARE HERE:
500 - Internal server error

HOME

CPSHOP|

|

|

EMAIL MARTY
  marty.net message board
  « 500 - Internal server error »
Welcome, Guest. Please Login or Register.
12/13/17 at 13:14:21
Home Help Search Login Register
   marty.net message board
   About cpshop
   Installation Help
   500 - Internal server error
(Moderator: Marty)
Pages: 1 Reply Notify of replies Send the topic Print 
   Author  Topic: 500 - Internal server error  (Read 5697 times)
bige2533
White Dragon
**

Posts: 24




   

500 - Internal server error
« on: 08/02/09 at 15:14:43 »
Reply with quote Modify message

I followed the instructions and included the items from the windows install sticky but still get the error when trying to go to: http://trailsticker.com/cgi-bin/cpadmin.pl

I uploaded the files in ASCII mode, confirmed the perl path #!/usr/bin/perl, set the $script_dir, set the $cpshop_filename, and changed the permissions on the files using plesk since I couldn't do it using my ftp client. Any other suggestions?
« Last Edit: 07/22/10 at 23:09:16 by bige2533 » Logged
bige2533
White Dragon
**

Posts: 24




   

Re: 500 - Internal server error
« Reply #1 on: 08/03/09 at 18:33:47 »
Reply with quote Modify message

I have also tried to upload the files with multiple ftp clients.
Logged
Marty
Administrator Dragon
*****

Gender: male
Posts: a whole lot



That's me. :)
   

WWW E-Mail
Re: 500 - Internal server error
« Reply #2 on: 08/04/09 at 01:05:17 »
Reply with quote Modify message

What error are you getting in your error log?
Logged

--
Regards,
Marty·.¸¸.·´¯`·.¸¸.-> marty@marty.net
bige2533
White Dragon
**

Posts: 24




   

Re: 500 - Internal server error
« Reply #3 on: 08/04/09 at 18:30:38 »
Reply with quote Modify message

I'm not sure if I have access to the error logs with lunarpages. All I could find was the IIS log file. Also, I tried the install in a 'store' directory under the root directory not in cgi-bin as well with no luck.

#Software: Microsoft Internet Information Services 7.0
#Version: 1.0
#Date: 2009-08-05 00:45:44
#Fields: date time s-sitename s-computername s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs-version cs(User-Agent) cs(Cookie) cs(Referer) cs-host sc-status sc-substatus sc-win32-status sc-bytes cs-bytes time-taken
2009-08-05 01:03:47 W3SVC32732 CRUSH 67.210.122.220 GET /cgi-bin/store/cpadmin.pl - 80 - 76.25.48.6 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+6.0;+en-US;+rv:1.9.0.12)+Gecko/2009070611+Firefox/3.0.12+(.NET+CLR+3.5.30729) - - trailsticker.com 500 19 5 1380 419 46
2009-08-05 01:03:51 W3SVC32732 CRUSH 67.210.122.220 GET /cgi-bin/store/cpshop.pl - 80 - 76.25.48.6 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+6.0;+en-US;+rv:1.9.0.12)+Gecko/2009070611+Firefox/3.0.12+(.NET+CLR+3.5.30729) - - trailsticker.com 500 19 5 1380 418 46
2009-08-05 01:04:04 W3SVC32732 CRUSH 67.210.122.220 GET /cgi-bin/store/cptest.pl - 80 - 76.25.48.6 HTTP/1.1 Mozilla/5.0+(Windows;+U;+Windows+NT+6.0;+en-US;+rv:1.9.0.12)+Gecko/2009070611+Firefox/3.0.12+(.NET+CLR+3.5.30729) - - trailsticker.com 500 19 5 1380 418 62
« Last Edit: 08/04/09 at 19:18:58 by bige2533 » Logged
bige2533
White Dragon
**

Posts: 24




   

Re: 500 - Internal server error
« Reply #4 on: 08/06/09 at 15:00:20 »
Reply with quote Modify message

I had support at Lunarpages investigate the problem and this turned out to be an issue with the web.config file. Looks like the cpadmin.pl is working and I'll be able to check on everything else this evening.
Logged
dreamcaster
Green Dragon
*

Posts: 1



Go Scots!
   

E-Mail
Re: 500 - Internal server error
« Reply #5 on: 12/15/09 at 22:28:50 »
Reply with quote Modify message

What was your outcome?  I'm having problems installing the scripts myself.  We get the same internal server 500 error.  Thanks!
Logged
bige2533
White Dragon
**

Posts: 24




   

Re: 500 - Internal server error
« Reply #6 on: 12/16/09 at 08:58:39 »
Reply with quote Modify message

Here is what was explained to me in the support ticket to lunarpages. I am using a windows host hence the plesk control panel. Not sure if this will help you though...


Hello,

I have looked over this issue. I have found and duplicated the issue. The issue was partially related to permissions on the cgi-bin directory however I also found another issue that was also most of the cause. I have looked into the web.config file and had noticed that the needed entries for the plesk control panel were missing. I renamed your web.config file to web.back.config and created a new web.config file with only the needed entries for plesk to store the IIS information for your account. Then I ran a permissions check and repair. All services are now functioning and you can verify this using the cgi-bin directly  If you have any other questions please feel free to reply to this ticket and we will assist you further.

Thank you for your patience and understanding while dealing with this issue.
« Last Edit: 07/22/10 at 23:13:05 by bige2533 » Logged
web2sign
Green Dragon
*

Posts: 1



Go Scots!
   

Re: 500 - Internal server error
« Reply #7 on: 05/25/10 at 02:32:54 »
Reply with quote Modify message

solved...
« Last Edit: 05/25/10 at 20:44:19 by web2sign » Logged
Pages: 1 Reply Notify of replies Send the topic Print 
Jump to:


marty.net message board (http://www.marty.net/cgi/marty/board/messageboard)

Powered by YaBB 1 Gold - Release (Yet Another Bulletin Board)
Copyright © 2000-2001, X-Null. All Rights Reserved.